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1.  Technical Guidelines 
 
 
Topic 
Description  

This user guide allows the user to setup and configure the Personal Computer 
(PC), to access the WP Online functions provided by MOM. 
 
It is assumed that the user of the WP Online system is familiar with the use of 
web browsers to access the internet. As such, usage of the web browsers will 
not be covered in this user guide. 
 
 
At the end of this topic, you will be able to: 
Setup and configure the PC, to access the WP Online functions provided by 
MOM. 
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1.1 Recommended PC Configuration 
 
The minimum and recommended hardware and software requirements are below: 
 

S/N Hardware/ 
Software 

Minimum PC 
Configuration 

Recommended PC Configuration 

1 PC 
- Pentium processor 
450 MHz 
- 64 MB RAM 
- 1 GB Hard-disk 

- Pentium processor 1.0 GHz 
- 256 MB RAM 
- 2 GB Hard-disk 
 

2 Web Browser 
Internet Explorer (IE) 
version 5.0 and above  
 
OR  
 
Netscape 
Communicator (NC) 
version 7.1 and above. 
 

Internet Explorer (IE) version 6  
 
 
OR 
 
Netscape Communicator (NC) version 
7.1 
 

3 Operating System 
Able to support the 
above Web Browser 
versions. 
 
For IE5.0, Windows  
95 / 98 / 98SE / NT4.0 
(SP2). 
Refer to www.msn.com 
for the Operating 
System for Internet 
Explorer web browsers. 
 
For NC7.1, Windows  
95 / 98 / NT 4.0 (SP2). 
Refer to 
www.netscape.com for 
the Operating System 
for Netscape 
Communicator web 
browsers. 
 

Able to support the above Web 
Browser versions. 
 
For IE6, Windows 
98 / 98SE / ME / NT 4.0 (SP6a) / 2000 
/ XP 
Refer to www.msn.com for the 
Operating System for Internet 
Explorer web browsers. 
 
For NC7.1, Windows  
98 / 98SE / ME / NT 4.0 / 2000 / XP 
Refer to www.netscape.com for the 
Operating System for Netscape 
Communicator web browsers. 
 

4 Printer Any Laser Jet Printer 
 

Any Laser Jet Printer 

5 Modem 
56kbps 
 

ADSL or Broadband Access 
 
(Please refer to your Internet Service 
Provider for the PC requirements.) 
 

 
 

http://www.msn.com/�
http://www.netscape.com/�
http://www.msn.com/�
http://www.netscape.com/�
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ADSL = Asymmetric Digital Subscriber Line, generally offered at downstream data rates from 512 
Kbps to about 6 Mbps. 

 
1.2 Installing Barcode Fonts 
 
STEP 1: Click on ‘Download Information’ and click on the ‘Bar Code Font’ as shown in Figure 1.2-1. 
 
Note: You will be prompted to save the barcode font in your PC. Simply save it to C:\ or a directory 
of your choice. 
 

 
Figure 1.2-1 

 
STEP 2: After successfully saving the barcode font to your computer, follow the steps below to 
setup the barcode fonts in your PC. 
 
STEP 3: Click on ‘Start’ - > ‘Setting’ - > ‘Control Panel’. 
 
STEP 4: Double click on the ‘Fonts’ icon. 
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STEP 5: Select ‘Install New Font.’ in the ‘File’ menu of the Fonts dialog box. (Figure 1.2-2) 
 

 
Figure 1.2-2 
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STEP 6: Go to the directory in which the font was downloaded and decompressed, and highlight the 
name of the font. (Figure 1.2-3) 
 

 
Figure 1.2-3 

 
STEP 7: Click ‘OK’ to end the installation. 
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1.3 Internet Explorer Setup 
 

1.3.1 Page Setup (Compulsory New Settings) 
 
STEP 1: Start ‘Internet Explorer’ by a double click of its icon. 
 
STEP 2: Select ‘Page Setup’ in the ‘File’ menu in Internet Explorer. 
 

 
Figure 1.3-1 

 
STEP 3: Remove all the wordings in the boxes under ‘Header’ and ‘Footer’. (Figure 1.3-1) 
 
STEP 4:  
 
For Internet Explorer 5.0: 
Fill in the Margins of the page in inches: Top is 0.166”, Bottom is 0.166”, Left is 0.75” and Right is 
0.25”. 
 
For Internet Explorer 6.0: 
Fill in the Margins of the page in inches: Top is 0.166”, Bottom is 0.166”, Left is 0.75” and Right is 
0.236”. 
 
STEP 5: Click the OK button. 
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1.3.2 Cache Setup (Compulsory New Settings) 
 
STEP 1: Select the ‘Tools’ menu, follow by ‘Internet Options’ 
 

 
Figure 1.3-2 

 
STEP 2: Under the ‘Temporary Internet files’ section, click on ‘Settings…’ (Figure 1.3-2) 
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STEP 3: Under ‘Check for newer versions of stored pages’, click on ‘Every visit to the page’ on the 
top left hand corner as shown below. (Figure 1.3-3) 
 

 
Figure 1.3-3 

 
STEP 4: Click on the ‘OK’ button, for the new settings to take place. 
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1.3.3 Javascript Setup (Original Settings by IE) 
 
STEP 1: Select ‘Tools’ menu in Internet Explorer as shown below. 
 

 
Figure 1.3-4 

 
 
STEP 2: Choose the ‘Internet Options’ under the ‘Tools’ menu and the following will be shown. 
 

 
Figure 1.3-5 
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STEP 3: Select the ‘Security’ tab and below screen will be shown. There will be a number of zones 
shown namely Internet, Local intranet, Trusted sites, and Restricted sites. Please make sure that 
yours is set at Internet. 
 

 
Figure 1.3-6 
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STEP 4: Click on the ‘Custom Level’ command box and Security Settings window appears. 
 

 
Figure 1.3-7 
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STEP 5: Scroll down to ‘Scripting’ section and make sure that ‘Active scripting’, ‘Allow paste 
operations via script’, and ‘Scripting of Java applets’ are set to ‘Enable’. 
 

 
Figure 1.3-8 
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1.3.4 Cookie Setup (Original Settings by IE) 
 
STEP 1: Select the ‘Tools’ menu, follow by ‘Internet Options’ 
 
For Internet Explorer 5.0: 
 
STEP 2: Click on the ‘Security’ tab. (Figure 3.1) 
 

 
Figure 3.1 

 
STEP 3: Scroll down to the ‘Cookies’ section, and check that cookies and their permission are 
enabled. 
 
For Internet Explorer 6.0: 
 
STEP 2: Click on the ‘Privacy’ tab. (Figure 3.2) 
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Figure 3.2 

 
STEP 3: Click on the ‘Advanced’ button. 
 

 
Figure 3.3 

 
STEP 4: Check that ‘First-party Cookies’ and ‘Third-party Cookies’ have ‘Accept’ selected. (Figure 
3.3) 
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1.3.5 Popup Setup (Original Settings by IE) 

1.3.5.1 Microsoft Windows XP Service Pack 2 Built-in Pop-Up Blocker Setup 
 
With the release of Microsoft’s Service Pack 2 (SP2), Pop-Up blocking is now directly integrated 
into Internet Explorer. Note that by default, Pop-Up blocking is enabled within SP2. This section i.e 
1.3.5.1 is only applicable to those using Windows XP Service Pack 2. 
 
STEP 1: Select the ‘Tools’ menu in Internet Explorer  
 

 
Figure 1.3-9 

 
STEP 2: Choose the ‘Pop-up Blocker’ and click ‘Turn Off Pop-up Blocker’. 
 

1.3.5.2 Alternate Pop-Up Blockers Setup 
 
STEP 1: Right click on your toolbar as shown below. Kindly make sure that only ‘Standard Buttons’, 
‘Address Bar’, ‘Links’, and ‘Lock the Toolbars’ are checked. 
 

 
Figure 1.3-10 
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1.3.5.3 Allowed Sites Additions for Internet Explorer 
 
STEP 1: Select the ‘Tools’ menu in Internet Explorer and below screen will show. 
 

 
Figure 1.3-11 

 
STEP 2: Choose the ‘Internet Options’ under the Tools menu and the following will show. 
 

 
Figure 1.3-12 
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STEP 3: Select the ‘Privacy’ tab and below screen will be shown. 
  

 
Figure 1.3-13 
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STEP 4: Click on ‘Settings’ and below screen will be shown. 
 

 
Figure 1.3-14 

 
STEP 5: Enter the allowed sites one at a time in the "Address of Web site to allow:” text box and 
click on 'Add' button.  Continue doing this until all the sites are displayed in the "Allowed sites:" box. 
The list of allowed sites is as follows. 

a. payment.consumerconnect.com.sg               
 b. www.enets.com.sg  
 c. www.enets.sg               
 d. www.jxgateway.com               
 e. dbsd2pay.dbs.com (for DBS/POSB Account holders)               
 f. uniservices1.uobgroup.com (for UOB Account holders)               
 g. www.citibank.com.sg (for Citibank Account holders)  
 h. www.ocbc.com (for OCBC Account holders)  
 i.  www.fairpriceplus.com (for FairPrice Plus Account holders) 
 j.  www.psi.gov.sg 
Note: You should refer to the WP Online main page (after logging in) regularly for the 
updated list of allowed sites. 
 
STEP 6: Repeat Step 5 till you finish adding allowed sites. 
 
STEP 7: Click ‘OK’. 
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1.3.6 SSL Setup (Original Settings by IE) 
 
STEP 1: Select ‘Tools’ menu, follow by ‘Internet Options’. 
 
STEP 2: Select the ‘Advanced’ tab. 
 

 
Figure 4 

 
STEP 3: Scroll down to the ‘Security’ section. Ensure that ‘Use SSL 3.0’ is selected. (Figure 4) 
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1.4 Netscape Communicator Setup 
 

1.4.1 Page Setup (Compulsory New Settings) 
 
STEP 1: Start ‘Netscape Communicator’ by a double click of its icon. 
 
STEP 2: Select ‘Page Setup’ in the ‘File’ menu in Netscape. 
 
 
STEP 3:  
 
For Netscape 7.1: 
Make sure all the tabs under the ‘Header and Footer’ section are set to ‘–blank-‘. (Figure 5.1) 
 

 
Figure 5.1 

 
STEP 4:  
 
For Netscape 7.1: 
Fill in the Margins of the page in millimeters: Top is 14mm, Bottom is 20mm, Left is 10mm and 
Right is 10mm. (Figure 5.1) 
 
STEP 5: Click the OK button. 
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1.4.2 Cache Setup (Compulsory New Settings) 
 
STEP 1: Go to ‘Edit’ menu -> ‘Preferences..’ under Netscape. 
 
STEP 2:  

 
For Netscape 7.1: 

Under the ‘Advanced’ feature, click on the ‘Cache’ section. Ensure that the ‘Every time I view the 
page’ near the middle portion of the screen is selected as shown below. (Figure 5.3) 

 
 

 
Figure 5.3 

 
STEP 3: Click on the ‘OK’ button.
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1.4.3 Javascript Setup (Original Settings by Netscape) 
 
STEP 1: Go to ‘Edit’ menu -> ‘Preferences..’ under Netscape. 
 
STEP 2:  

 
For Netscape 7.1: 

Under ‘Advanced’ feature, ensure that the checkbox besides ‘Enable Java’ is checked as shown 
below. (Figure 6.1) 

 

 

 

 
Figure 6.1 

 

 

 

 



Technical Guidelines 
______________________________________________________________________________ 

______________________________________________________________________________ 
 

WP Online: User Guide  Page 25 of 38  

1.4.4 Cookie Setup (Original Settings by Netscape) 
 
STEP 1: Go to ‘Edit’ menu -> ‘Preferences..’ under Netscape. 

 
STEP 2:  

For Netscape 7.1: 

Select the ‘Privacy and Security’ heading, follow by the ‘Cookie’ branch. (Figure 7.1) Ensure that 
the ‘Enable cookies based on privacy settings’ is selected. 

 

 
Figure 7.1 
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1.4.5 PopUp Setup (Original Settings by Netscape) 
 
Note: Only for Netscape 7.1: 
 
STEP 1: Go to ‘Edit’ menu -> ‘Preferences..’ under Netscape. 
 
STEP 2: Under ‘Privacy and Security’, select ‘Popup Windows’. (Figure 8) 
 
STEP 3: Check to ensure that the ‘Block unrequested popup windows’ is not checked. 
 
 
 
 

 
Figure 8 
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1.4.6 SSL Setup (Original Settings by Netscape) 
 
For Netscape 7.1: 

STEP 1: Go to ‘Edit’ menu -> ‘Preferences..’ under Netscape. 
 

STEP 2: Select the ‘Privacy and Security’ section, follow by the SSL branch. (Figure 9.1) 

 
Figure 9.1 

 
STEP 3: Ensure that the ‘Enable SSL version 3’ is checked. 
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1.5 Installation of Adobe Reader 
 
STEP 1: Proceed to Adobe website1

 

 to download the latest Adobe Acrobat Reader installation file.  
(As at the point of this document, Adobe Reader 8 is the latest version of Adobe Acrobat Reader, 
the following installation instruction will base on screen-shots from Adobe Reader 8) 

STEP 2: Once you have downloaded the installation file.  Run the file to start the installation 
process.  The first screen you will see upon execution is figure 10.1 below. 
 

 
Figure 10.1 

 
STEP 3: Click on the ‘Next >’ button to confirm on the folder to install Adobe Reader into and you 
will see figure 10.2 on the next page. 
 

                                                 
1 http://www.adobe.com/products/acrobat/readstep2_allversions.html 

http://www.adobe.com/products/acrobat/readstep2_allversions.html�
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Figure 10.2 

 
STEP 4: Click on ‘Install’ button to proceed with the installation. 
 

 
Figure 10.3 

 
STEP 5: Once installation kicks started, you can see the progress of the installation as shown in 
figure 10.3 above.  Please wait for the installation to complete. 
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Figure 10.4 

 
STEP 6: Once installation completed, you will see figure 10.4 above.  Click on ‘Finish’ button to exit 
setup. 
 
STEP 7: If you are prompted to restart the computer, please do so before you proceed. 
 
STEP 8: To test the installation of your Adobe Reader, either open a PDF file, if you have one. You 
may also test the installation by login to WP Online again and access the ‘Conditions of Work 
Permit / Visit Pass for Foreign Worker’ link under ‘Download Information’.  You will see the screen 
shown in figure 10.5 if you have successfully installed Adobe Reader. 
 

 
Figure 10.5 



Technical Guidelines 
______________________________________________________________________________ 

______________________________________________________________________________ 
 

WP Online: User Guide  Page 31 of 38  

STEP 9: To test the printing of a file viewed under Adobe Reader, please click on the icon as 
highlighted in the Red Box in figure 10.5 (on the previous page).  The below screen in figure 10.6 
will appear. 
 

 
Figure 10.6 

 
STEP 10: Please ensure ‘Page Scaling’ is set to ‘None’ as shown in figure 10.6 and ensure the 
correct printer is selected at the top.  Click ‘OK’ button to send the displayed file to the printer.  The 
printed copy should appear exactly as what is displayed on screen. 
 

1.5.1 Recommended Adobe Reader Settings 
STEP 1: Activate your Adobe Reader by either double-clicking on the Adobe Reader icon on your 
Desktop or from your Start Menu, under ‘All Programs’. 

 

STEP 2: Click on ‘Edit’ followed by ‘Preferences…’ as seen in Figure 10.7 on the next page. 
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Figure 10.7 

 

STEP 3: In Adobe Reader version 8, the Preferences dialog window will appear as below. 

 
Figure 10.8 

 

STEP 4: Click on ‘General’ in the box on the left and unchecked the box ‘Create links from URLs’. 

 

STEP 5: Click on the ‘OK’ button at the bottom to complete the setup. 
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1.6 Frequently Asked Questions 
 

1.6.1 How do I configure my Printer Settings to print the forms nicely? 
 
In your printer settings: set the paper size to A4, with the print resolution set to minimum dpi, and 
use white paper for printing. 
 

1.6.2 Can I use multiple windows to access the WP Online service? 
 
No. Only use windows generated by our pages. 
 

1.6.3 Should I use the web browser’s back and forward buttons? 
 
No. Only use the menu and buttons from our WP Online pages. 
 

1.6.4 What if I forgot to Logged out? 
 
The WP Online services will automatically timeout in 30 minutes, when there is no action from the 
user in this time period. As a form of good practice, do remember to logout so as to safeguard 
yourself against unauthorized access. 
 

1.6.5 Do I need to clear my cache in the Internet Browsers, after logging out? 
 
As a form of good practice, clearing the cache will further ensure that the information you keyed in 
will not be seen by another person. This is a recommended move, whenever you feel that the 
accessed information is sensitive to you. 
 

1.6.6 Who should I call if I encounter a technical issue? 
 
You can call our technical support staff at 64385122 during office hours. 
 

1.6.7 Why does my letter shrink in size when printed via Adobe Reader? 
 
The ‘Page Scaling’ setting should be set to ‘None’ to prevent automatic scale down of the letter. 
From the top menu-bar, click on ‘File’ and then ‘Print’. You may then change this setting from the 
pop-up window as illustrated below.  



Technical Guidelines 
______________________________________________________________________________ 

______________________________________________________________________________ 
 

WP Online: User Guide  Page 34 of 38  

 
1.6.8 How to return to my letter if I clicked on the URL on the new browser window? 
1.6.8 My letter appeared on a new browser window after I clicked the ‘Print’ button on the 

letter selection page. Thereafter, I have also clicked on the URL displayed on the 
letter and I am brought to another web page. How can I return to my letter? 

 
Close the window that is displaying the new web page. The main window where WP Online letter 
selection page is displaying should be brought back to you. Click on the ‘Print’ button again to 
retrieve your letter. 

1.6.9 How to return to my letter if I clicked on the URL on the Adobe window? 
1.6.9 My letter appeared on an Adobe Reader window after I clicked the ‘Print’ button on 

the letter selection page. Thereafter, I have also clicked on the URL displayed on the 
letter and my browser displaying the letter selection page is replaced with another 
web page. How can I return to my letter? 

 
Your browser’s ‘Back’ button may not work, you need to login again to WP Online. Repeat the steps 
till you return to the letter selection page, and then click on the ‘Print’ button again. If you would like 
to prevent this accidental click on the URL from happening again, you can refer to Section 1.5.1 
Recommended Adobe Reader Settings to disable any hyperlinks on the URLs shown on the 
PDF files. 
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1.6.10 How to check whether my computer have Adobe Reader installed? 
 
STEP 1: Usually, you should see this icon on your desktop once Adobe Reader is installed: 

 
STEP2: If you cannot find this icon, click on “Start” button (usually at the lower left corner of your 
desktop) followed by “All Programs”.  In the list of programs displayed, you should be able to find 
Adobe Reader, if it has been installed.  See below image on how it may look like. 

 
 

1.6.11 What will i see if I try to open a PDF letter with no Adobe Reader installed? 
1) You will be prompted to save the Letter instead of viewing it. 

 
2) Once the file is saved and you try to open it, you may be prompted with the below dialogue 

box depending on your Windows version (image below is from a Windows XP PC). 

 
3) Clicking on “OK” button with the “Use the Web service to …” option and you are still 

connected to the Internet, your browser will open the below web page with a link to 
download Adobe Reader. 
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You can click on the link to download a free copy of Adobe Reader for your installation. 
 
1.6.12 What should I do if I encountered an alert citing a site’s security certificate problem? 
The WP Online eServices upgraded its security certificate from Entrust (L1C cert) on 12 Aug 2010.  
The new SSL certificate is running on 2048 bits which would require additional authentication with 
the Chain Server located at Entrust.   
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If you encountered any of the following alerts on your web browser, your PC may not be updated 
with the latest security certificate store.   
 
Message in Internet Explorer version 5 & 6 

 
 
Message in Internet Explorer version 7 & above 
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Message in Netscape Communicator (NC) version 7.1 and above 

 
 
Please click on the following links and follow the on screen instructions to update your browser’s 
security certificate if you encounter the above alerts: - 
 

a. First file 

b. Second file. 

The download will update your computer security store to accept the new certificate and to access 
to the secured eServices. If your download and installation of the two files are successful, you 
should not see the security alert anymore. 
 
 
 

http://www.mom.gov.sg/MOMDoc/EntrustCA2048.crt�
http://www.mom.gov.sg/MOMDoc/EntrustL1C.crt�
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